PAKETE PER APT INSTALLIEREN ETCH 4.0

Aus OPPServer.net Wiki | OPPs Wiki
Version vom 29. April 2013, 14:11 Uhr von SOliver (Diskussion | Beiträge) (SOliver verschob Seite ETCH/4.0 nach PAKETE PER APT INSTALLIEREN ETCH 4.0)
(Unterschied) ← Nächstältere Version | Aktuelle Version (Unterschied) | Nächstjüngere Version → (Unterschied)
Zur Navigation springen Zur Suche springen

PAKETE PER APT INSTALLIEREN (Stand 06.02.2009) [ © Oliver Schuetz aka OppTupacShakur | http://OPPServer.net | http://unix.oppserver.net ]

SUDO INSTALLIEREN (als root, danach muss man mit visudo seinen user eintragen)

aptitude install sudo


MAKE TOOLS INSTALLEN

sudo aptitude install gcc g++ make zip bzip2 unzip psmisc libc6 libc6-dev unrar


KERNEL SOURCEN INSTALLEN

sudo aptitude install linux-headers-`uname -r` linux-source-`uname -r`


X-WINDOW SYSTEM INSTALLIEREN

sudo aptitude install x-window-system-core


KDE INSTALLIEREN

sudo aptitude install kde-core kdeaddons kdeadmin kdeartwork kdegraphics kdemultimedia kdenetwork kdepim kdeutils kdewebdev kde-i18n-de gtk-qt-engine


KDM INSTALLIEREN

sudo aptitude install kdm


TEXT INTERNET BROWSER INSTALLIEREN

sudo aptitude install links


NVIDIA TREIBER INSTALLIEREN Vorher mit uname -a gucken welcher Kernel installiert ist.

sudo aptitude install linux-image-2.6.xx.xx nvidia-kernel-2.6.xx.xx nvidia-settings nvidia-xconfig

nvidia-xconfig ausfuehren, damit nvidia als Treiber verwendet wird. Neustarten um den neuen Kernel zu laden.


NVIDIA TREIBER MANUELL INSTALLIEREN Vorher mit uname -a gucken welcher kernel installiert ist.

sudo aptitude install xorg-dev xlibmesa-dri xlibmesa-gl xlibmesa-glu mesa-utils libgl1-mesa-dri libgl1-mesa-glx linux-headers-2.6.xx.xx linux-source-2.6.xx 

Nun wechseln wir den runlevel, falls man in KDE oder Gnome angemeldet war, dort nun abmelden und im anmeldebildschirm mit "alt + N" (oder auf Menue klicken und dann textkonsolenmudus waehlen) in den textmodus wechseln. Hier melden wir uns als root an und laden dann von http://www.nvidia.de/object/linux_de.html den passenden Treiber, zb

wget http://de.download.nvidia.com/XFree86/Linux-x86/1.0-xxxx/NVIDIA-Linux-x86-1.0-xxxx-pkg1.run

Dann installieren wir den treiber mit:

sudo sh NVIDIA-Linux-x86-1.0-xxxx-pkg1.run

Und folgen den Anweissungen bei der Installation. Normalerweisse wird die xorg.conf automatisch angepasst, falls nicht muessen wir das per Hand, zb mit

sudo nano /etc/X11/xorg.conf

machen, und dort folgendes evtl aendern:

Diese Zeilen loeschen

Driver "nv"
(oder Driver "vesa")
(oder Driver "fbdev")

und mit dieser Zeile ersetzen:

Driver "nvidia"

Diese Zeilen (wenn vorhanden) loeschen:

Load "dri"
Load "GLCore"

Und diese Zeile hinzufuegen:

Load "glx"

Bei Problemen in der Sektion "Screen" diese Zeile hinzufuegen:

Option  "NvAgp" "3"

Speichern und dann noch folgenden Befehl ausfuehren:

sudo modprobe -q agpgart

Dann am besten einmal rebooten ( oder "init 1" mit root login und dann wieder "init 5") und anschliessend einmal mit "glxinfo" als sysuser in einem Terminal testen, ob "direct rendering: Yes" dort steht.


GRAFIKPROGRAMME INSTALLIEREN

sudo aptitude install foomatic-db-gimp-print gimp gimp-help-de gimp-print gimp-svg gimp-texturize gimp-python inkscape


BROWSER INSTALLIEREN Weitere apt-sourcen hinzufuegen fuer Opera:

deb http://deb.opera.com/opera/ etch non-free
sudo gpg --keyserver pgp.mit.edu --recv-keys 6A423791
sudo gpg --armor --export 6A423791 | apt-key add -
sudo aptitude update
sudo aptitude install iceweasel iceweasel-l10n-de opera flashplugin-nonfree


MULTIMEDIA INSTALLIEREN Weitere apt-sourcen hinzufuegen (siehe http://www.debian-multimedia.org):

deb http://debian-multimedia.informatik.uni-erlangen.de/debian-multimedia/ etch main
sudo gpg --keyserver pgp.mit.edu --recv-keys 1F41B907
sudo gpg --armor --export 1F41B907 | apt-key add -
sudo aptitude update
sudo aptitude install xine xine-ui mplayer-586 mencoder-586 kmplayer mplayer-skin-blue mplayerplug-in amarok amarok-xine w32codecs libxvidcore4 libxvidcore-dev avifile-xvid-plugin xvid4conf vlc mozilla-plugin-vlc ffmpeg faad faac libfaad2-dev libfaac-dev liba52-0.7.4 liba52-dev lame liblame-dev
sudo aptitude install libogg-dev libtheora-dev libvorbis-dev alsa alsa-oss alsa-tools alsa-utils alsa-source libx264-dev libmp4v2-dev libid3tag0-dev libmad0-dev libsndfile1-dev libflac-dev libasound2-dev


WINE Weitere apt-sourcen hinzufuegen (siehe http://www.debian-multimedia.org):

deb http://wine.budgetdedicated.com/apt etch main #WineHQ - Debian 4.0 "Etch"
deb-src http://wine.budgetdedicated.com/apt etch main #WineHQ - Debian 4.0 "Etch"
sudo wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
sudo aptitude update

FUER AELTERE WINE VERSIONEN

sudo aptitude install wine xwine wine-utils libwine-print libwine-arts libwine-alsa

FUER DIE NEUSTE WINE VERSION

sudo aptitude install wine


JAVA

sudo aptitude install sun-java5-jdk sun-java5-plugin

Oder wenn man auch etch.backports in der sources.list hat:

sudo aptitude install sun-java6-jdk sun-java6-plugin


OPENOFFICE.ORG

sudo aptitude install openoffice.org openoffice.org-help-de openoffice.org-hyphenation-de openoffice.org-l10n-de openoffice.org-spellcheck-de-ch openoffice.org-thesaurus-de-ch openoffice.org-thesaurus-de openoffice.org-kde msttcorefonts ttf-bitstream-vera ttf-freefont ttf-gentium ttf-junicode ttf-lucida ttf-xfree86-nonfree


SVN

sudo aptitude install subversion subversion-tools


CVS

sudo aptitude install cvs


Mercurial (HG)

sudo aptitude install mercurial


CHATTEN

sudo aptitude install xchat kopete


APACHE

sudo aptitude install apache

APACHE 2

sudo aptitude install apache2 libapache2-svn

MYSQL

sudo aptitude install mysql-server mysql-admin

PHP4(APACHE)

sudo aptitude install libapache-mod-php4 php4-cgi php4-xslt php4-mcrypt php4-curl php4-imagick php4-mysql php4-pgsql php4-dev php4-cli phpmyadmin

PHP4(APACHE2)

sudo aptitude install libapache2-mod-php4 php4-cgi php4-xslt php4-mcrypt php4-curl php4-imagick php4-mysql php4-pgsql php4-dev php4-cli phpmyadmin

PHP5(APACHE)

sudo aptitude install libapache-mod-php5 php5-cgi php5-xsl php5-mcrypt php5-curl php5-imagick php5-mysql php5-pgsql php5-tidy php5-dev php5-cli phpmyadmin

PHP5(APACHE2)

sudo aptitude install libapache2-mod-php5 php5-cgi php5-xsl php5-mcrypt php5-curl php5-imagick php5-mysql php5-pgsql php5-tidy php5-dev php5-cli phpmyadmin


WEITERE SERVER DIENSTE (SSH, TELNET)

sudo aptitude install ssh proftpd samba smbfs smbclient nfs-common nfs-kernel-server sendmail spamassassin tightvncserver xtightvncviewer telnetd smbldap-tools

PROFTPD MIT MYSQL SUPPORT

sudo aptitude install proftpd-mysql

PROFTPD tls/ssl Installation http://unix.oppserver.net/debian/proftpd_tls-ssl_faq_debian (Vorlagen http://unix.oppserver.net/proftpd/sample-configurations/opp_example_proftpd.conf - http://unix.oppserver.net/proftpd/sample-configurations/opp_example_welcome.msg)


POSTFIX, COURIER UND SQUIRREL WEBMAIL

http://unix.oppserver.net/debian/postfix_debian_install


WEBMIN Weitere apt-sourcen hinzufuegen (siehe http://www.debian-multimedia.org):

deb http://download.webmin.com/download/repository sarge contrib
sudo aptitude update
sudo aptitude install webmin

USERMIN Weitere apt-sourcen hinzufuegen (siehe http://www.debian-multimedia.org):

deb http://download.webmin.com/download/repository sarge contrib
sudo aptitude update
sudo aptitude install usermin


UTILITIES

sudo aptitude install sux krename


CD-BRENNEN

sudo aptitude install k3b k3b-i18n cdrdao dvd+rw-tools cdrecord


ADOBE ACROBAT READER

sudo aptitude install acroread mozilla-acroread


FTP

sudo aptitude install gftp


TELEVISION

sudo aptitude install tvtime


DVD

sudo aptitude install libdvdcss2 libdvd0


OPENSSL

sudo aptitude install openssl

Wie man SSL einrichtet siehe hier:

http://unix.oppserver.net/debian/debian_openssl_installieren_und_certs_erstellen_faq


DM-CRYPT

sudo aptitude install cryptsetup

Wie man mit dm-crypt verschluesselt siehe hier:

http://unix.oppserver.net/crypt/dm-crypt_faq


CRYPTOLOOP

sudo aptitude install loop-aes-modules loop-aes-utils loop-aes-testsuite sharutils

Wie man mit cryptoloop verschluesselt siehe hier:

http://unix.oppserver.net/crypt/cryptoloop_faq


SPRACHCODE AENDERN

sudo dpkg-reconfigure locales

ggf. de_DE.ISO-8859-15@euro einstellen


GRUNDINSTALLATION ABSCHLIESSEN

sudo aptitude dist-upgrade